Drupal 6 PHP conflict

The version of PHP available on the CRC VMs (running Ubuntu 14.04 LTS) is PHP 5.5.9. Drupal 6, upon which Drupal Commons 2 is based, turns out to be potentially incompatible with this; from their website:

  • Drupal 6: PHP 5.x only (5.2.5 or higher recommended). Warning: support for PHP 4.x has been dropped. Drupal core should work with PHP 5.3.x, but PHP 5.3.x and higher may produce errors or unexpected behavior especially for contributed modules and themes.

Standard practice would be to load the website with PHP 5.5.9 and then "walk back" PHP versions until you find one that doesn't cause "errors or unexpected behavior." Using outdated PHP, however, is bad security practice and the CRC does not allow it.

To my knowledge, no one ever tried running the site as-is with PHP 5.5.9 to see if there are real errors. Regardless of PHP compatibility, however, Drupal 6 itself reached end-of-life on 24 February 2016. Being unsupported software, it is not safe to install on public VMs at the CRC regardless of PHP version.

-- Main.JoelG - 2016-11-16


Topic revision: r1 - 2016-11-16, JoelG
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback